





























































    
         
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Content - Default" />
  
    <meta name="oid" content="25150120" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=526e59f23adea6ff3a89779b11e84031" />
  <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=526e59f23adea6ff3a89779b11e84031" />
  <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=526e59f23adea6ff3a89779b11e84031" />
  <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=526e59f23adea6ff3a89779b11e84031" />

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/karnak-6-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="The Coast Halifax RSS: Whole Site" href="https://www.thecoast.ca/halifax/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="The Coast Halifax RSS: News + Opinion Section" href="https://www.thecoast.ca/halifax/Rss.xml?oid=957802" />
    
    
      <link rel="alternate" type="application/rss+xml" title="The Coast Halifax RSS: City" href="https://www.thecoast.ca/halifax/Rss.xml?oid=4435354" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="The Coast Halifax RSS: Comments on City" href="https://www.thecoast.ca/halifax/Rss.xml?id=comments&amp;oid=4435354" />
      
    
  

  

  
    <script>window.__FBAPIv__ = 'v3.2'</script>
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
      
      <script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=70d51da15a07ba855c71948f37462a75"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=70d51da15a07ba855c71948f37462a75"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  
  

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.thecoast.ca\/halifax\/Profile", "https:\/\/posting.thecoast.ca\/halifax\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="273771202932-str5blh8ptiqeraooup6i4fdhbf6k042.apps.googleusercontent.com">
  

    
  

  
  <meta name="verify-v1" content="WcM2joOISr6lgVELoN5rmh/64RtkN4MZElPU2JbaUlc=" />




<!-- Begin Google Publisher Tag header. -->

  <script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
              var gads = document.createElement('script');
              gads.async = true;
              gads.type = 'text/javascript';
              var useSSL = 'https:' == document.location.protocol;
              gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
              var node = document.getElementsByTagName('script')[0];
              node.parentNode.insertBefore(gads, node);
            })();
          </script>
          <script type='text/javascript'>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</script>

<!-- End Google Publisher Tag header. -->

<script src="https://coastmart.altperks.com/remote/DealsGoingFast.js"></script>




<link href="https://plus.google.com/109004454798276698863" rel="publisher" />

<meta name="verify-v1" content="o26nximNxf5ft3uZj7btV+AwCzQjREyd7y2/sR6+NW4=" />


<!-- Begin Google Web Fonts API calls -->
<link href="https://fonts.googleapis.com/css?family=Roboto:400,500,700,900|News+Cycle:400,700|Merriweather:900|Yanone+Kaffeesatz:400,700" rel="stylesheet">
<!-- End Google Web Fonts API calls -->

<!-- Begin LiteTooltip.css resources -->
  <link href="https://www.thecoast.ca/scripts/litetooltip_v2.0/css/litetooltip.min.css" rel="stylesheet" />
  <!-- End LiteTooltip.css resources -->


<!-- AdSense -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-5846270086092028",
    enable_page_level_ads: true
  });
</script>

<!-- VISA Tracking Code for https://thecoast.ca -->

      <script>
        (function (v, i, s, a) {
          v._visaSettings = {v: "0.1", i: "cb7f87455a3fced1fa5ca159036a479c", s: "dbe87bc6-1e66-11e9-b589-901b0edac50a", a: 1};
          _v = i.getElementsByTagName('head')[0];_a=_v;
          _i = i.createElement('script');
          _s =_i; _s.async = "async"; _s.src = s + a + v._visaSettings.v;
          _a.appendChild(_s);
        })(window, document, '//app-worker.visitor-analytics.io/main', '.js?v=');
      </script>

<!-- VISA Tracking Code for https://thecoast.ca -->

<!-- Reboo design app code May 2019 START -->

<link href="https://cdn.reboo.io/embed/aa0d7ff81ca523a07/reboo.min.css" rel="stylesheet"></link>
<script src="https://cdn.reboo.io/embed/aa0d7ff81ca523a07/reboo.min.js"></script>

<!-- Reboo design app code May 2019 END -->




<!-- Press Patron Jan 2020 START -->

<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=yLwPBYCRtGaBwL5zRbfgjHqU";
	fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>

<!-- Press Patron Jan 2020 END -->
  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Halifax to rally for rent control this weekend | City | Halifax, Nova Scotia | THE COAST" />
  <meta name="description" content="The policy, which exists in PEI, Ontario, Manitoba and BC would mean landlords have to stop jacking up the rent by however much they feel like." />
  <meta name="keywords" content="Rental housing, crisis, Halifax housing, Airbnb, Rent control, Halifax news, breaking news, municipal politics, city hall news, local business, downtown development, the mayor, city councillors, Shoptalk, On Patrol, Dartmouth, Bedford, Sackville, HRM, Nova Scotia, NS, newspaper, magazine, The Coast,, Newspaper, Halifax, Dartmouth, Bedford, Sackville, HRM, Nova Scotia, NS, Savage Love, newspaper, Best Of, Savage, CBC, Chronicle Herald, CTV, happy hour, film, music, Dalhousie, Saint Mary&#39;s, SMU, DAL, MSVU, NSCAD, NSCC" />
  <title>Halifax to rally for rent control this weekend | City | Halifax, Nova Scotia | THE COAST</title>

  
  
    <meta name="date" content="2020-11-06 13:29:05" />
  

  
  
  
    <meta name="author" content="Seyitan Moritiwon">
  

  
  
  <meta name="news_keywords" content="rental housing, crisis, halifax housing, airbnb, rent control, halifax news, breaking news, municipal politics, city hall news, local business" />

  
  

  
  
  
    <link rel="image_src" href="https://media2.fdncms.com/thecoast/imager/u/slideshow/25150124/img_20201106_131742_817.jpg" />
    <meta name="thumbnail" content="https://media2.fdncms.com/thecoast/imager/u/slideshow/25150124/img_20201106_131742_817.jpg" />
  

  
    
      <link rel="canonical" href="https://www.thecoast.ca/halifax/halifax-to-rally-for-rent-control-this-weekend/Content?oid=25150120" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.thecoast.ca/halifax/halifax-to-rally-for-rent-control-this-weekend/Content?oid=25150120" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="https://www.thecoast.ca/halifax/halifax-to-rally-for-rent-control-this-weekend/Content?oid=25150120&media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="https://www.thecoast.ca/halifax/halifax-to-rally-for-rent-control-this-weekend/Content?oid=25150120" />
    
  

  
    <meta property="fb:app_id" content="166200076783953" />
  

  
  <meta property="og:site_name" content="The Coast Halifax" />
  <meta property="og:title" content="Halifax to rally for rent control this weekend" />

   
  
    

    
    

    
    

    <meta property="og:image" content="https://media2.fdncms.com/thecoast/imager/u/slideshow/25150124/img_20201106_131742_817.jpg" />

    
      <meta property="og:image:width" content="590" />
      <meta property="og:image:height" content="787" />
    
  

  
  
    <meta property="og:description" content="The policy, which exists in PEI, Ontario, Manitoba and BC would mean landlords have to stop jacking up the rent by however much they feel like." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    
    

    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media2.fdncms.com/thecoast/imager/u/slideshow/25150124/img_20201106_131742_817.jpg">

    
    

    

    <meta name="twitter:site" content="@TwitCoast">
    <meta name="twitter:title" content="Halifax to rally for rent control this weekend">
    <meta name="twitter:description" content="The policy, which exists in PEI, Ontario, Manitoba and BC would mean landlords have to stop jacking up the rent by however much they feel like.">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">25150120</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20201106135239</Attribute>
        <Attribute name="creationdate">20201106131449</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20201106132905</Attribute>
            <Attribute name="releasedate">20201106</Attribute>
            <Attribute name="releaseepoch">1604683745</Attribute>
            <Attribute name="title">Halifax to rally for rent control this weekend</Attribute>
            <Attribute name="author">23800215</Attribute>
            <Attribute name="authorname">Seyitan Moritiwon</Attribute>
            <Attribute name="authorsortname">Moritiwon, Seyitan</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"https:\/\/www.thecoast.ca\/halifax\/halifax-to-rally-for-rent-control-this-weekend\/Content?oid=25150120"
          },
          "headline": "Halifax to rally for rent control this weekend",
          
            "description": "The rent at Aidan Tompkins’ three-bedroom apartment on Almon Street went up by 29 percent in 2019. He and his roommates were paying $1,345 for the three-bedroom unit before the notice from his landlord came four months before lease renewal.",
          
          
            "image": {
              "url": "https:\/\/media2.fdncms.com\/thecoast\/imager\/u\/original\/25150124\/img_20201106_131742_817.jpg",
              "width": 756,
              "height": 1008,
              "@type": "ImageObject"
            },
          
          "datePublished": "2020-11-06T13:29:05",
          "dateModified": "2020-11-06T13:52:39",
          
            "author": {
              "name": "Seyitan Moritiwon",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "The Coast Halifax",
            
              
              
              
              "logo": {
                "url": "https:\/\/www.thecoast.ca\/imager\/b\/google-amp-logo\/808579\/8e57\/The_Coast_site_no_give_up.png",
                "width": 850,
                "height": 315,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


</head>





  <body id="Content" class="City ContentDefault Karnak6Zone news">



<!-- Begin LiteTooltip.js resources -->
  <script type="text/javascript" src="/scripts/litetooltip_v2.0/js/litetooltip.min.js"></script>
  <!-- End LiteTooltip.js resources -->

<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  <div id="PressPatronBanner" class="Leader ContentDefault ">
  <div id="pp-banner"></div>
</div>











  <div id="FullBackgroundAdDFP" class="Leader ContentDefault " style="display: none;">
    
      <!-- /1020031/Widewallpaper -->
          <div id="div-gpt-ad-widewallpaper" style="" data-content-type="ad" data-slot="/1020031/Widewallpaper" data-output="asynchronous" data-width="1600" data-height="1200">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-widewallpaper');
                });
              </script>
          </div>
    
  </div>

  <script type="text/javascript">
  googletag.cmd.push(function() {
    var positionFullBackgroundAd = function(){
      var pageWidth = document.documentElement.clientWidth || document.body.clientWidth
      var componentWidth = jQuery('#FullBackgroundAdDFP').outerWidth()
      var newLeft = Math.floor((pageWidth - componentWidth)/2+(-3)) + 'px'
      jQuery('#FullBackgroundAdDFP').css({'left':newLeft})
    }

    jQuery(window).resize(function(){
      positionFullBackgroundAd()
      jQuery('#FullBackgroundAdDFP').show()
    })

    var targetSlot = Foundation.Ad.slots["div-gpt-ad-widewallpaper"]
    googletag.pubads().addEventListener('slotOnload', function(event) {
      var slot = event.slot;
      console.log('Impression for slot', slot.getSlotElementId(), 'became viewable.');

      if (slot === targetSlot) {
        console.log('div-gpt-ad-widewallpaper slotOnLoad fired');
        positionFullBackgroundAd()
        jQuery('#FullBackgroundAdDFP').show()
      }
    })
  })
  </script>















</div><!-- end gridLeader -->

<div id="gridClamp">

  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader ContentDefault " style="display:none">
        
        
          Switch to the <a href="https://m.thecoast.ca/halifax/halifax-to-rally-for-rent-control-this-weekend/Content?oid=25150120" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      
      function setRedirectHash() {
        if (location.hash) {
          jQuery("#MobileDetect a[media='handheld']").each(function() {
            var link = jQuery(this);
            link.attr('href', link.attr('href').split('#')[0] + location.hash);
          });
        }
      }
      setRedirectHash();

      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  

<style>
#CovidHeader {
 max-width: 100%;
box-sizing: border-box; 
position: relative;
z-index: -20;
}
#CovidHeader img {
max-width:100%;
height: auto;
background-color: white;
}
</style>

<div class="GlobalHeader ContentDefault " id="CovidHeader" style="width:980px; padding:0px; margin:0px auto -25px;box-sizing:border-box;">
<a href="/blogs/COVID19Needtoknow/" target="_blank"><img src="/binary/6f53/covid-header.png" width="980" height="191" alt="" /></a> 
</div>


  

  


  

  <div id="LogoSearchLogin" class="GlobalHeader ContentDefault ">
    
    
      
   
     <div id="HeadingLoginSearch">
        
        

        
        

        
        

        
        

        
        
        

        
          
          

          
          

          
        
          
          

          
          

          
        
          
          

          
          

          
        
          
          

          
          

          
        
          
          

          
          

          
        
          
          

          
          

          
        
          
          

          
          

          
        
          
          

          
          

          
        
          
          

          
          

          
        
          
          

          
          

          
        
            
            

            
            
              
            

            
            

            <div class="secHeader headerNews">
            
              <a href="https://www.thecoast.ca/halifax/news-opinion/Section?oid=957802">
                News + Opinion
              </a>
            
          </div>

          

        
        <div id="loginSearchBox">
        
        <div id="header-login">
          
          <ul id="LogoSearchLogin-login" data-view="loggedin" style="display:none">
            <li class="loginImage"><img src="/images/icons/loginIcon.png" alt="Login or Register" /></li>
            <li><strong data-label="username">Username</strong> / </li>
            <li><a href="https://posting.thecoast.ca/halifax/MyProfile">View Profile</a> / </li>
            <li><a href="https://posting.thecoast.ca/halifax/Profile/MySettings">Edit Profile</a> / </li>
            <li><a href="https://www.thecoast.ca/halifax/Logout">Log&nbsp;Out</a></li>
          </ul>
          <ul data-view="loggedout" style="display:none">
            <li class="loginImage"><img src="/images/icons/loginIcon.png" alt="Login" /></li>
            <li><a href="#LogIn">Log in</a></li>
          </ul>
        </div><!-- #header-login -->
        <script>
          new Foundation.LoginRequiredComponent("LogoSearchLogin");
        </script>

      

      
      <div id="header-searchbox">
        
          <form class="prepTextForm" id="searchbox_013113823529494842305:9r0wnbysleo" action="https://posting.thecoast.ca/halifax/Search">
            <input type="hidden" name="cx" value="013113823529494842305:9r0wnbysleo" />
            <input type="hidden" name="cof" value="FORID:9" />
            <input type="text" name="q" size="25" />
            <input type="submit" name="sa" value="Go" />
          </form>
          
      </div><!-- #header-searchbox -->
    </div>

      </div>

      <div id="LogoNLinks">
        
        <div id="logo"><a href="https://www.thecoast.ca/">The Coast Halifax</a></div>
   
        
        <div id="headerLinks">
        <a class="hdrSubscr" href="https://eepurl.com/bYZNob" target="_blank">Newsletters</a>
        <p>Follow Us</p> 
        <a class="hdrTwt social" href="https://twitter.com/TwitCoast" target="_blank">The Coast on Twitter</a></li>
        <a class="hdrFbook social" href="https://www.facebook.com/TheCoastHalifax/" target="_blank">The Coast on Facebook</a>
        <a class="hdrInstagram social" href="https://www.instagram.com/thecoasthalifax/" target="_blank">The Coast on Instagram</a>
        <a class="hdrRSS social" href="https://www.thecoast.ca/halifax/Syndication">The Coast's RSS Feeds</a>
        <a class="hdrMbl" href="https://m.thecoast.ca/">Mobile</a>
      </div><!-- #headerLinks -->  
      </div>         

      

    

  </div><!-- #LogoSearchLogin -->


















  <div id="NavigationHorizontal" class="GlobalHeader ContentDefault  ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_COVID19">
          <a href="https://www.thecoast.ca/blogs/COVID19Needtoknow/"  >COVID-19</a>
        </li>
        
      
        

        

        

        

        <li class="navCurrent" id="NavItem_news">
          <a href="https://www.thecoast.ca/halifax/news-opinion/Section?oid=957802"  class="subnav_link" id="SNAVL_news">News + Opinion</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_bitch">
          <a href="https://www.thecoast.ca/blogs/LovetheWayWeBitch/"  class="subnav_link" id="SNAVL_bitch">Bitch</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_dining">
          <a href="https://www.thecoast.ca/halifax/food-drink/Section?oid=957796"  class="subnav_link" id="SNAVL_dining">Food + Drink</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_arts">
          <a href="https://www.thecoast.ca/halifax/arts-culture/Section?oid=957805"  class="subnav_link" id="SNAVL_arts">Arts + Culture</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Home">
          <a href="https://www.thecoast.ca/halifax/Home"  class="subnav_link" id="SNAVL_Home">Home</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_bestof">
          <a href="https://bestofhalifax.com"  class="subnav_link" id="SNAVL_bestof">Best Of</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Archives">
          <a href="https://www.thecoast.ca/halifax/IssueArchives?year=2020"  >Archives</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_SUPPORTTHECOAST">
          <a href="https://www.thecoast.ca/halifax/SupportTheCoast/Page"  >SUPPORT THE COAST</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse </h3>
            <ul class="subnav_content" id="SNAV_" style="display:none;">
          

          

          <li class="">
            <a href="http://www.thecoastclassifieds.ca"  title="">Browse All Categories</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.thecoastclassifieds.ca/usercheckout.php"  title="">Place an Ad</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Event Listings</h3>
            <ul class="subnav_content" id="SNAV_entertainment" style="display:none;">
          

          

          <li class="searchItem">
            <a href="https://www.thecoast.ca/halifax/EventSearch"  title="">See all events</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/addevent"  title="">Add an event</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Bitch</h3>
            <ul class="subnav_content" id="SNAV_bitch" style="display:none;">
          

          

          <li class="">
            <a href="https://www.thecoast.ca/blogs/LovetheWayWeBitch/"  title="">Love the Way We Bitch</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/blogs/Lovethewaywelove/"  title="">Love the Way We Love</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/SubmitABitchOrLove/Page"  title="">Submit a Bitch or Love</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse News + Opinion</h3>
            <ul class="subnav_content" id="SNAV_news" style="display:none;">
          

          

          <li class="">
            <a href="https://www.thecoast.ca/blogs/RealityBites/"  title="">Reality Bites</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/blogs/COVID19Needtoknow/"  title="">COVID-19</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/city/Category?oid=4435354"  title="">City News</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/blogs/Shoptalk/"  title="">ShopTalk</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/environment/Content?category=4435179"  title="">Enviro</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/voice-of-the-city/Category?oid=3472646"  title="">Voice</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/free-will-astrology/Content?category=1412708"  title="">Horoscopes</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/blogs/Opinionated/"  title="">Opinionated</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/letters/Category?oid=4435362"  title="">Letters</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/SubmitALetter/Page"  title="">Write a Letter</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/savage-love/Category?oid=957830"  title="">Savage Love</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/Poll"  title="">The Poll</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Music</h3>
            <ul class="subnav_content" id="SNAV_music" style="display:none;">
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/feature/Category?oid=4427121"  title="">Music Feature</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/festivals/Category?oid=4427120"  title="">Festivals</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/ArticleArchives?category="  title="">Music Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/blogs/TheScene/"  title="">The Scene</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.thecoast.ca/halifax/EventSearch?eventSection=981499&sortType=date&eventCategory=981533"  title="">Big Ticket Concerts</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.thecoast.ca/halifax/EventSearch?eventSection=981499&narrowByDate=Today"  title="">Live Music Listings</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.thecoast.ca/halifax/LocationSearch?locationCategory=977663"  title="">Search Music Venues</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Food + Drink</h3>
            <ul class="subnav_content" id="SNAV_dining" style="display:none;">
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/food-and-drink/Section?oid=957796"  title="">Food &amp; Drink Home Page</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/blogs/RestaurantandBarNews/"  title="">The Feed</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.thecoast.ca/halifax/LocationSearch?locationSection=993376"  title="">Search Restaurants</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.thecoast.ca/halifax/LocationSearch?locationSection=993377"  title="">Search Bars</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/beer-guide/Category?oid=1088150"  title="All the beer, all over town">Beer Guide</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/ArticleArchives?section=957796"  title="">Archives</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://bestofhalifax.com"  title="">Best of Halifax</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Arts + Culture</h3>
            <ul class="subnav_content" id="SNAV_arts" style="display:none;">
          

          

          <li class="">
            <a href="https://www.thecoast.ca/blogs/ArtAttack/"  title="">Art Attack</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/culture/Category?oid=4426702"  title="">Culture</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/dance/Category?oid=992987"  title="">Dance</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/ArticleArchives?category=4443392"  title="">Comics</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/film-tv/Category?oid=4427096"  title="">Film + TV</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/literary/Category?oid=957818"  title="">Literary</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/theatre/Category?oid=1804246"  title="">Theatre</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/visual-art/Category?oid=957815"  title="">Visual Art</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.thecoast.ca/halifax/LocationSearch?locationCategory=977662"  title="">Search Galleries &amp; Museums</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.thecoast.ca/halifax/EventSearch?eventSection=981502"  title="">Visual Arts Listings</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://bestofhalifax.com"  title="">Best of Halifax</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse City Guides</h3>
            <ul class="subnav_content" id="SNAV_lifestyle" style="display:none;">
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/back-to-school/Category?oid=995076"  title="">Back to School</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/beer-guide/Category?oid=1088150"  title="">Beer Guide</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/home-style-guide/Category?oid=993449"  title="">Homes Halifax</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/pride/Category?oid=1559197"  title="">Halifax Pride</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/hot-summer-guide/Category?oid=992992"  title="">Hot Summer Guide</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/fall-wine-guide/Category?oid=3400503"  title="">Fall Wine</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/fall-arts-preview/Category?oid=4427108"  title="">Fall Arts Preview</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/career-minded-sponsor-content/Category?oid=3442481"  title="">Career Minded sponsor content</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.thecoast.ca/halifax/LocationSearch?locationSection=993381"  title="">Search Shops</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/ArticleArchives?section=1527418"  title="">Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Best Of</h3>
            <ul class="subnav_content" id="SNAV_bestof" style="display:none;">
          

          

          <li class="">
            <a href="https://bestofhalifax.com"  title="">Vote in the 2020 BOH</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/the-25th-annual-best-of-halifax-readers-choice-awards-winners/BestOf?oid=22791256"  title="">BOH 2019</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/your-best-of-halifax-2018-readers-choice-awards-winners/BestOf?oid=18680347"  title="">BOH 2018</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/your-best-of-halifax-2017-readers-choice-awards-winners/BestOf?oid=10518858"  title="">BOH 2017</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/best-of-halifax-readers-choice-awards-2016/BestOf?oid=5772153"  title="">BOH 2016</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/BestOf?year=2015"  title="">BOH 2015</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Dating</h3>
            <ul class="subnav_content" id="SNAV_dating" style="display:none;">
          

          

          <li class="">
            <a href="http://halifaxmatch.ca"  title="">Halifax Match</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/savage-love/Content?category=957830"  title="">Savage Love</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/love-and-sex-issue/Category?oid=1076505"  title="">Love and Sex Issue</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.thecoast.ca/halifax/this-is-how-we-do-it-the-results-of-our-2019-sex-dating-survey/Content?oid=20600321"  title="Results from The Coast's latest sorta-scientific study of the dating, single, hook-up and partnered-up scene in Halifax.">Sex + Dating Survey 2019</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>
    
  
  <!-- true == "true"
         && true == "devel" -->


<!-- End #NavigationHorizontal -->








  <div id="NavigationSubnav" class="GlobalHeader ContentDefault ">
    
        <ul class="page-subnav" id="SNAV_news">
      
      

      <li class="subnav-item first">
        <a href="https://www.thecoast.ca/blogs/RealityBites/" target="_self">Reality Bites</a>
      </li>

      
    
      

      <li class="subnav-item ">
        <a href="https://www.thecoast.ca/blogs/COVID19Needtoknow/" target="_self">COVID-19</a>
      </li>

      
    
      

      <li class="subnav-item ">
        <a href="https://www.thecoast.ca/halifax/city/Category?oid=4435354" target="_self">City News</a>
      </li>

      
    
      

      <li class="subnav-item ">
        <a href="https://www.thecoast.ca/blogs/Shoptalk/" target="_self">ShopTalk</a>
      </li>

      
    
      

      <li class="subnav-item ">
        <a href="https://www.thecoast.ca/halifax/environment/Content?category=4435179" target="_self">Enviro</a>
      </li>

      
    
      

      <li class="subnav-item ">
        <a href="https://www.thecoast.ca/halifax/voice-of-the-city/Category?oid=3472646" target="_self">Voice</a>
      </li>

      
    
      

      <li class="subnav-item ">
        <a href="https://www.thecoast.ca/blogs/Opinionated/" target="_self">Opinionated</a>
      </li>

      
    
      

      <li class="subnav-item ">
        <a href="https://www.thecoast.ca/halifax/free-will-astrology/Content?category=1412708" target="_self">Horoscopes</a>
      </li>

      
    
      

      <li class="subnav-item ">
        <a href="https://www.thecoast.ca/halifax/letters/Category?oid=4435362" target="_self">Letters</a>
      </li>

      
    
      

      <li class="subnav-item ">
        <a href="https://www.thecoast.ca/halifax/SubmitALetter/Page" target="_self">Write a Letter</a>
      </li>

      
    
      

      <li class="subnav-item ">
        <a href="https://www.thecoast.ca/halifax/savage-love/Category?oid=957830" target="_self">Savage Love</a>
      </li>

      
    
      

      <li class="subnav-item last">
        <a href="https://www.thecoast.ca/halifax/Poll" target="_self">The Poll</a>
      </li>

      
    
        </ul>
      
  </div>


    <div class="HeaderLeaderboardAd">
      <!-- /1020031/Leaderboard_New -->
          <div id="div-gpt-ad-leaderboard_new" style="" data-content-type="ad" data-slot="/1020031/Leaderboard_New" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-leaderboard_new');
                });
              </script>
          </div>
    </div>

    <!-- end gridHeader -->
  </div>

  <div id="gridMain">

    <!-- ZoneA -->
    <div id="gridMainColumn">
      


  
  















  
  
  

  
  
  

  
 
  




  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="MainColumn ContentDefault ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:14%; height: 20px; float:left;">
        



<div id="FacebookShareButtonCount" class="MicroComponent ToolBarHorizontal ">
  <div class="fb-share-button" data-type="button_count" data-href="https://www.thecoast.ca/halifax/halifax-to-rally-for-rent-control-this-weekend/Content?oid=25150120"></div>
</div></div> <div class="l0" style="width:14%; height: 20px; float:left;">







  
  

  

  <a href="https://twitter.com/share?text=Halifax%20to%20rally%20for%20rent%20control%20this%20weekend&amp;url=https%3A%2F%2Fwww.thecoast.ca%2Fhalifax%2Fhalifax-to-rally-for-rent-control-this-weekend%2FContent%3Foid%3D25150120" class="twitter-share-button" data-count="horizontal">Tweet</a>
  <script>
    dnLoadScript("https://platform.twitter.com/widgets.js", true);
  </script>

</div> <div class="l0" style="width:14%; height: 20px; float:left;">


  

  

  

  <a href="https://pinterest.com/pin/create/button/?description=Halifax%20to%20rally%20for%20rent%20control%20this%20weekend&amp;media=https%3A%2F%2Fmedia2.fdncms.com%2Fthecoast%2Fimager%2Fu%2Fslideshow%2F25150124%2Fimg_20201106_131742_817.jpg&amp;url=https%3A%2F%2Fwww.thecoast.ca%2Fhalifax%2Fhalifax-to-rally-for-rent-control-this-weekend%2FContent%3Foid%3D25150120" class="pin-it-button" count-layout="none">Pin It</a>
  <script>
  Foundation.documentReady.then(function () {
    new Foundation.Script("https://assets.pinterest.com/js/pinit.js", true);
  })
  </script>

</div> <div class="l0" style="width:14%; height: 20px; float:left;">


  <a class="toggleActivator saveAction requiresLogin" title="My Favorites" href="https://posting.thecoast.ca/halifax/Profile/MyFavorites?add=25150120">
    Favourite
  </a>
  <div class="togglePanel" data-toolsoid="25150120" data-toolsajaxmacro="addObject" style="display:none">
    <div class="loading">Saving&hellip;</div>
    <div class="ajaxUpdater" style="display:none"></div>
  </div>


</div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="printAction" title="Print" href="https://www.thecoast.ca/halifax/halifax-to-rally-for-rent-control-this-weekend/Content?mode=print&amp;oid=25150120" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="https://posting.thecoast.ca/halifax/Tools/EmailFriend?oid=25150120" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0 last" style="width:14%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=ra-4f9ab8e8139f396b" addthis:url="https://www.thecoast.ca/halifax/halifax-to-rally-for-rent-control-this-weekend/Content?oid=25150120" addthis:title="Halifax to rally for rent control this weekend" addthis:description="The policy, which exists in PEI, Ontario, Manitoba and BC would mean landlords have to stop jacking up the rent by however much they feel like." class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f9ab8e8139f396b", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  





  
    <div id="StoryBreadcrumb" class="MainColumn ContentDefault  news___opinion city">
      <p class="issueInfo ">
        <span class="date">
          
            <a href="https://www.thecoast.ca/halifax/IssueArchives?issue=24992533">November 06, 2020</a>
          
        </span>

  			
          <a href="https://www.thecoast.ca/halifax/news-opinion/Section?oid=957802">News + Opinion</a>
        
        
          &raquo; <a href="https://www.thecoast.ca/halifax/ArticleArchives?category=4435354">City</a>
        
      </p>
    </div> <!-- end StoryBreadcrumb -->
  











  
  
  
  
  
    
  








  

  

  
    <div id="StoryHeader" class="MainColumn ContentDefault   home_top_featured">
      <div class="storyHead">
        
        <h1 class="headline headline-25150120">Halifax to rally for rent control this weekend&nbsp;</h1>        
        
          <h2 class="subheadline">The policy, which exists in PEI, Ontario, Manitoba and BC would mean landlords have to stop jacking up the rent by however much they feel like.</h2>
        
        
          

          <cite class="byline">
            <span class="byAttribute">By</span> <a href="https://www.thecoast.ca/author/seyitan-moritiwon" rel="author">Seyitan Moritiwon</a>
               
          </cite>

          

        
      </div>
    </div> <!-- end StoryHeader -->
  















<div id="StoryLayout" class="MainColumn ContentDefault  home_top_featured">

  

    

    


































    
    

    
      
    
    
    
    
      
      

      
              
    

      
     
       
      
      
      
      
    
      <div id="storyBody" class="page1 home_top_featured">
        
      
        

        
        
          <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/thecoast/imager/u/original/25150124/img_20201106_131742_817.jpg" class="zoomable" rel="contentImg_gal-25150120" title="A notice for a unit currently for rent at 2323 Agricola Street. A two-bedroom unit in the same building was renting for $1245 in 2017. That&#39;s an increase of 43 percent over three years. - SUBMITTED">                  <img src="https://media2.fdncms.com/thecoast/imager/u/blog/25150124/img_20201106_131742_817.jpg?cb=1604685143" width="630" height="600" alt="A notice for a unit currently for rent at 2323 Agricola Street. A two-bedroom unit in the same building was renting for $1245 in 2017. That&#39;s an increase of 43 percent over three years. - SUBMITTED" srcset="" />                </a>                                                                                                           <ul style="width:630px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCaption">                      A notice for a unit currently for rent at 2323 Agricola Street. A two-bedroom unit in the same building was renting for $1245 in 2017. That's an increase of 43 percent over three years.                    </li>                                                                                                                            <li class="imageCredit">                                              SUBMITTED                                          </li>                                                                                                </ul>                                                       </div>   <br>
 <span class="fdnDropCap">T</span>he rent at Aidan Tompkins’ three-bedroom apartment on Almon Street went up by 29 percent in 2019. He and his roommates were paying $1,345 for the three-bedroom unit before the notice from his landlord came four months before lease renewal. <br>
  <br>
  “It hit us pretty hard. We had to reassess our budget, had to cut a lot of things out,” says Tompkins who’s earning just above minimum wage as a cook. <br>
 <br>
  In The Coast’s <a href="/halifax/feature-tk/Content?oid=22299093" target="_blank">2019 rental housing survey</a>, 45 percent of respondents said their rent was going up in the next year—and on average, rents were increasing by five percent. In Nova Scotia, there’s no restriction on how much rent can increase, just that it can only happen once a year. Across Canada, provinces with controls on rent increases cap the jump around two percent—with Ontario putting an all-out freeze on rent increases for 2021. <br>
  <br>
  Low vacancy rates, booming population growth, an influx of Airbnbs and slow building on new units <a href="/halifax/6-developments-you-should-know-about/Content?oid=22298725" target="_blank">all contribute to Halifax’s landlord’s rental market</a> that regularly sees huge increases like Tompkins’—whose 29 percent increase in 2019 was upped again this year by $75 a month. This one he did not honour because it wasn’t presented by the landlord with the required <a href="https://beta.novascotia.ca/sites/default/files/documents/1-1764/residential-tenancies-guides-renting-en.pdf" target="_blank">four months’ notice</a>. <br>
  <br>
  On Saturday, Tompkins, who’s a member of ACORN a rental tenancy union for low and moderate income tenants, will be lending his voice at a rally for rent control happening at the Grand Parade outside City Hall at 2 pm. <br>
  <br>
  The rally will see attendees march to the province house as they demand a change in Nova Scotia’s renting policy. Fight for 15 and Dalhousie Legal Aid are going to be present in solidarity says Hannah Wood, Peninsula Chair of ACORN. “It’s an opportunity for people to come and be part of the fight for rental reform and rent control.” <br>
  <br>
  She says she’s heard of increases of up to $900. “Right now, we are really in a crisis point with housing where housing is becoming increasingly unaffordable for people and people’s rights to stay in their homes are being trampled upon.” <br>
  <br>
Wood maintains they will continue to fight until they get what they want—rent control. “I hope to show both the city and the province and the Liberal party that we’re very serious about this,” she says. <br>
 <br>
  Not only is this a rally for a provincial change with regards to rent, Wood also hopes people who come out can be educated holistically about other situations in the province “and learn how they can be informed and organized and how they can fight for rent control themselves individually.” Like how rent control did exist in Nova Scotia until 1993, when then-premier John Savage’s Liberal government took it away. <br>
  <br>
  Any effort to put it back in place falls on the provincial government, but almost 70 percent of Halifax’s newly-election regional council<a href="/halifax/a-look-inside-halifax-regional-councils-head-and-the-next-four-years/Content?oid=25098872" target="_blank"> told The Coast</a> the policy should exist in Halifax. (John Savage’s son, mayor Mike Savage, answered no.)  <br>
  <br>
Like many others in Halfiax, because of the pandemic Tompkins is only getting three to four days of work, but still has to pay the same amount of rent. The state of emergency in place because of COVID-19 means he can't be evicted while it's in place, but beyond that, Tompkins says the fair rent act favours only landlords. “Our fair rent act is called just that—a fair rent act. But there’s nothing about it that’s fair.”
        

        
        

        
        
      </div>
    

  
  
</div> <!-- end StoryLayout -->



 
  <div id="StoryTags" class="MainColumn ContentDefault ">
    <p class="tags">Tags: <a href="/halifax/ArticleArchives?category=4435354" rel="tag">City</a>, <a href="/halifax/ArticleArchives?tag=Rental%20housing" rel="tag">Rental housing</a>, <a href="/halifax/ArticleArchives?tag=crisis" rel="tag">crisis</a>, <a href="/halifax/ArticleArchives?tag=Halifax%20housing" rel="tag">Halifax housing</a>, <a href="/halifax/ArticleArchives?tag=Airbnb" rel="tag">Airbnb</a>, <a href="/halifax/ArticleArchives?tag=Rent%20control" rel="tag">Rent control</a></p>          
  </div> <!-- end StoryTags -->







  
  
  

  <!-- UIkit CSS -->
  <link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=73e9dae96d9526a38cb04987628b4c2d" />

  <!-- UIkit JS -->
  <script src="/fdn-system/assets/pub/scripts/uikit.min.js?cb=73e9dae96d9526a38cb04987628b4c2d"></script>
  <script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js?cb=73e9dae96d9526a38cb04987628b4c2d"></script>


  

  <style>
    @media (min-width: 640px){
      div[id] .uk-child-width-1-3\@exs > * {
         width: calc(100% * 1 / 3.001);
      } 
    }
    #gridMainColumn .uk-width-1-2\@es {
      width: 50%;
    }

    #gridMainColumn .uk-child-width-auto\@exs > * {
      width: auto;
    }
    
    .uk-root {
      font-size: 14px;
    }
  </style>











<!-- Begin LiteTooltip init -->
  <script>
  (function($){
  $('.litetooltip-hotspot-wrapper .hotspot').each(function () { 
      $(this).LiteTooltip({ title: $(this).find('.data-container').html() });
   });
  })(jQuery);
  </script>
  <!-- End LiteTooltip init -->










































  

  

  
  

  
    
  

  











<div id="PressPatronAppeal" class="MainColumn ContentDefault ">
  <h3><span class="headingText">Support The Coast</span></h3>
  <img src="/binary/3e24/OSPCOMP20201015A01.jpg" width="160" style="float: right; margin-left:10px;"/>
           
  <p>
    At a time when the city needs local coverage more than ever, <a href="https://www.thecoast.ca/halifax/SupportTheCoast/Page">we’re asking for your help</a> to support independent journalism. We are committed as always to providing free access to readers, particularly as we confront the impact of COVID-19 in Halifax and beyond.
  </p>
  <p>
    Read more about the work we do <a href="https://www.thecoast.ca/halifax/SupportTheCoast/Page">here</a>, or consider making a voluntary donation using the button below.  Thank you for your support!
  </p>
  <div class="pp-donate-button"></div>
</div>










  
  

  
  



    
    
    
    





















 








  
  

















  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="MainColumn ContentDefault ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:14%; height: 20px; float:left;">
        



<div id="FacebookShareButtonCount" class="MicroComponent ToolBarHorizontal ">
  <div class="fb-share-button" data-type="button_count" data-href="https://www.thecoast.ca/halifax/halifax-to-rally-for-rent-control-this-weekend/Content?oid=25150120"></div>
</div></div> <div class="l0" style="width:14%; height: 20px; float:left;">







  
  

  

  <a href="https://twitter.com/share?text=Halifax%20to%20rally%20for%20rent%20control%20this%20weekend&amp;url=https%3A%2F%2Fwww.thecoast.ca%2Fhalifax%2Fhalifax-to-rally-for-rent-control-this-weekend%2FContent%3Foid%3D25150120" class="twitter-share-button" data-count="horizontal">Tweet</a>
  <script>
    dnLoadScript("https://platform.twitter.com/widgets.js", true);
  </script>

</div> <div class="l0" style="width:14%; height: 20px; float:left;">


  

  

  

  <a href="https://pinterest.com/pin/create/button/?description=Halifax%20to%20rally%20for%20rent%20control%20this%20weekend&amp;media=https%3A%2F%2Fmedia2.fdncms.com%2Fthecoast%2Fimager%2Fu%2Fslideshow%2F25150124%2Fimg_20201106_131742_817.jpg&amp;url=https%3A%2F%2Fwww.thecoast.ca%2Fhalifax%2Fhalifax-to-rally-for-rent-control-this-weekend%2FContent%3Foid%3D25150120" class="pin-it-button" count-layout="none">Pin It</a>
  <script>
  Foundation.documentReady.then(function () {
    new Foundation.Script("https://assets.pinterest.com/js/pinit.js", true);
  })
  </script>

</div> <div class="l0" style="width:14%; height: 20px; float:left;">


  <a class="toggleActivator saveAction requiresLogin" title="My Favorites" href="https://posting.thecoast.ca/halifax/Profile/MyFavorites?add=25150120">
    Favourite
  </a>
  <div class="togglePanel" data-toolsoid="25150120" data-toolsajaxmacro="addObject" style="display:none">
    <div class="loading">Saving&hellip;</div>
    <div class="ajaxUpdater" style="display:none"></div>
  </div>


</div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="printAction" title="Print" href="https://www.thecoast.ca/halifax/halifax-to-rally-for-rent-control-this-weekend/Content?mode=print&amp;oid=25150120" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="https://posting.thecoast.ca/halifax/Tools/EmailFriend?oid=25150120" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0 last" style="width:14%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=ra-4f9ab8e8139f396b" addthis:url="https://www.thecoast.ca/halifax/halifax-to-rally-for-rent-control-this-weekend/Content?oid=25150120" addthis:title="Halifax to rally for rent control this weekend" addthis:description="The policy, which exists in PEI, Ontario, Manitoba and BC would mean landlords have to stop jacking up the rent by however much they feel like." class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f9ab8e8139f396b", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  




  

  
    <div class="uk-root">
  

  





<div class="componentGrid-TwoZones-Auto-Expand uk-root uk-width-1-1 uk-flex uk-flex-row uk-flex-wrap fdn-component-grid-row@m" uk-height-match data-component-grid-id="TopStoriesVideoPair">

  <div class="uk-width-1-1 uk-width-auto@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
    














  
  
  

  
      <div class="ComponentZoneA TopStoriesVideoPairresponsive  trending-by-day uk-root fdn-margin-vert TrendingContentList comp-landing-trending" data-component-id="TrendingContentList">
        <div class="fdn-component-header-block uk-margin ">

      

      <h3 class="fdn-component-header-text uk-margin-remove ">
        
          Trending
        
      </h3>

      

      
    </div>
        <ul class="pres-ContentListHeadline uk-list uk-list-divider">
    
    

    <li class="fdn-pres-item">
      <a class="uk-flex uk-flex-top" href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/11/02/covid-19-news-for-the-november-2-week">
        <p class="fdn-teaser-headline">
          COVID-19 news for the November 2 week
        </p>
      </a>
  </li>

    
 
  
    

    <li class="fdn-pres-item">
      <a class="uk-flex uk-flex-top" href="https://www.thecoast.ca/halifax/voice-of-the-city-the-show-must-go-on/Content?oid=25138425">
        <p class="fdn-teaser-headline">
          Voice of the city: The show must go on
        </p>
      </a>
  </li>

    
 
  
    

    <li class="fdn-pres-item">
      <a class="uk-flex uk-flex-top" href="https://www.thecoast.ca/halifax/do-you-ever-feel-like-a-plastic-bag-obsolete/Content?oid=25104374">
        <p class="fdn-teaser-headline">
          Do you ever feel like a plastic bag? Obsolete.
        </p>
      </a>
  </li>

    
 
  
        </ul>
        <script>
  jQuery(function () {
    var setHeights = function () {
      for(var item of document.querySelectorAll('[data-component-id="TrendingContentList"].trending-by-day li a')) {
        item.style.height = null
        item.style.height = item.getHeight() + 'px'
      }
    }
    window.addEventListener('resize', setHeights)
    window.addEventListener('orientationchange', setHeights)
    setHeights()
  })
  </script>
      </div>
    



    
  </div>

  <div class="uk-width-1-1 uk-width-expand@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
    <!-- 
        fetched: 2020-11-06 14:00 1 
        mode: content
        requestSite: thecoast
        id: 20310739
        vrd: null ()
        vri: 2 ()
        vrp: false ()
      -->

      

        

        

        
            <div class="ComponentZoneB TopStoriesVideoPairresponsive  no-foundation-imgeditor uk-root fdn-margin-vert TopStoriesVideo comp-content-topstoriesvideo" data-component-id="TopStoriesVideo">
    <div class="top-stories-video">
    <div class="uk-inline">
      <div class="carousel-items">
          
          

          

          

          <div class="item uk-overflow-hidden uk-animation-fade ">
            <a href="https://www.thecoast.ca/halifax/building-shaped-like-half-a-cruise-ship-will-come-to-halifaxs-waterfront-with-few-changes/Content?oid=24906331" target="_top">
              <img class="uk-animation-kenburns uk-transform-origin-top-left"
                   src="https://media1.fdncms.com/thecoast/imager/u/16x9-m/24917383/screen_shot_2020-10-01_at_4.42.08_pm.png" alt="">
            </a>
            <div class="uk-hidden uk-animation-slide-left" data-headline>
              <a class="carousel-headline" href="https://www.thecoast.ca/halifax/building-shaped-like-half-a-cruise-ship-will-come-to-halifaxs-waterfront-with-few-changes/Content?oid=24906331" target="_top"><strong>Building shaped like half a cruise ship will come to Halifax's waterfront with few changes</strong></a>
            </div>
          </div> 

          
        
          

          

          

          <div class="item uk-overflow-hidden uk-animation-fade uk-hidden">
            <a href="https://www.thecoast.ca/TheScene/archives/2020/09/03/whats-happening-in-halifax-this-labour-day-weekend" target="_top">
              <img class="uk-animation-kenburns uk-transform-origin-top-center"
                   src="https://media1.fdncms.com/thecoast/imager/u/16x9-m/24738456/image1.png" alt="">
            </a>
            <div class="uk-hidden uk-animation-slide-left" data-headline>
              <a class="carousel-headline" href="https://www.thecoast.ca/TheScene/archives/2020/09/03/whats-happening-in-halifax-this-labour-day-weekend" target="_top"><strong>What's happening in Halifax this Labour Day Weekend</strong></a>
            </div>
          </div> 

          
        
          

          

          

          <div class="item uk-overflow-hidden uk-animation-fade uk-hidden">
            <a href="https://www.thecoast.ca/TheScene/archives/2020/05/21/remembering-menz-and-mollyz" target="_top">
              <img class="uk-animation-kenburns uk-transform-origin-center-left"
                   src="https://media1.fdncms.com/thecoast/imager/u/16x9-m/24097782/screen_shot_2020-05-22_at_2.54.54_pm.png" alt="">
            </a>
            <div class="uk-hidden uk-animation-slide-left" data-headline>
              <a class="carousel-headline" href="https://www.thecoast.ca/TheScene/archives/2020/05/21/remembering-menz-and-mollyz" target="_top"><strong>Remembering Menz & Mollyz</strong></a>
            </div>
          </div> 

          
        
          

          

          

          <div class="item uk-overflow-hidden uk-animation-fade uk-hidden">
            <a href="https://www.thecoast.ca/halifax/nick-nemeroff-tells-us-a-joke/Content?oid=24079382" target="_top">
              <img class="uk-animation-kenburns uk-transform-origin-center-right"
                   src="https://media2.fdncms.com/thecoast/imager/u/16x9-m/24084645/screen_shot_2020-05-20_at_12.13.33_pm.png" alt="">
            </a>
            <div class="uk-hidden uk-animation-slide-left" data-headline>
              <a class="carousel-headline" href="https://www.thecoast.ca/halifax/nick-nemeroff-tells-us-a-joke/Content?oid=24079382" target="_top"><strong>Nick Nemeroff tells us a joke</strong></a>
            </div>
          </div> 

          
        
          

          

          

          <div class="item uk-overflow-hidden uk-animation-fade uk-hidden">
            <a href="https://www.thecoast.ca/halifax/some-tidal-bay-for-you-city-rollers/Content?oid=24048575" target="_top">
              <img class="uk-animation-kenburns uk-transform-origin-bottom-left"
                   src="https://media1.fdncms.com/thecoast/imager/u/16x9-m/24048580/tidal_bay_2019.png" alt="">
            </a>
            <div class="uk-hidden uk-animation-slide-left" data-headline>
              <a class="carousel-headline" href="https://www.thecoast.ca/halifax/some-tidal-bay-for-you-city-rollers/Content?oid=24048575" target="_top"><strong>Some Tidal Bay for you city rollers</strong></a>
            </div>
          </div> 

          
        
            </div>

      

      
      
        <div class="uk-position-top-left uk-position-small uk-flex uk-flex-row carousel-info-text">
          <div class="uk-width-auto uk-padding-small uk-text-bold">
            Top Stories
          </div>
          
        </div>
      

      
      
        <div class="uk-position-top-right uk-flex-top uk-position-small uk-width-1-6 carousel-info-icon uk-flex uk-flex-right">
          <img src="/apple-touch-icon-iphone.png" width="40">
        </div>
      

      
      <div class="uk-position-bottom-right uk-position-small uk-flex uk-flex-row">
        
        
          <div class="uk-flex-1 carousel-progress-block">
            
            
            <div class="carousel-progress-block-item"></div>
          </div> 
        
          <div class="uk-flex-1 carousel-progress-block">
            
            
            <div class="carousel-progress-block-item"></div>
          </div> 
        
          <div class="uk-flex-1 carousel-progress-block">
            
            
            <div class="carousel-progress-block-item"></div>
          </div> 
        
          <div class="uk-flex-1 carousel-progress-block">
            
            
            <div class="carousel-progress-block-item"></div>
          </div> 
        
          <div class="uk-flex-1 carousel-progress-block">
            
            
            <div class="carousel-progress-block-item"></div>
          </div> 
        
      </div>

      
      <div class="carousel-video-player uk-overlay-default uk-position-cover uk-hidden">
      </div>

      
      <div class="carousel-video-player-label video-player-label-mute-toggle uk-overlay-default uk-position-top-center carousel-button uk-padding-small uk-hidden">
        Advertisement:
        <span class="uk-margin-xsmall-right uk-hidden volume-icon" uk-icon="icon:fdn-volume;ratio:1.8"></span>
        <span class="uk-margin-xsmall-right uk-hidden volume-mute-icon" uk-icon="icon:fdn-volume-mute;ratio:1.8"></span>
      </div>

      
      <div class="carousel-video-player-countdown uk-position-bottom-right uk-hidden uk-flex uk-flex-middle uk-padding-small" style="color:white;font-weight:bold;text-shadow: 1px 1px #000000;">
      </div>

      
      <div class="carousel-prev carousel-button uk-position-center-left">
        <span uk-icon="icon: triangle-left; ratio: 2"></span>
      </div>

      
      <div class="carousel-pause carousel-button uk-position-center uk-hidden">
        <span uk-icon="icon: fdn-pause; ratio: 3.5"></span>
      </div>

      
      <div class="carousel-play carousel-button uk-position-center uk-hidden">
        <span uk-icon="icon: play; ratio: 3.5"></span>
      </div>

      
      <div class="carousel-next carousel-button uk-position-center-right">
        <span uk-icon="icon: triangle-right; ratio: 2"></span>
      </div>

      
      <div class="carousel-volume carousel-button uk-position-bottom-left uk-width-1-4 uk-hidden uk-flex uk-flex-middle uk-padding-xsmall">
        <div class="carousel-volume-mute-toggle">
          <span class="uk-margin-xsmall-right uk-hidden volume-icon" uk-icon="icon:fdn-volume;ratio:1.3"></span>
          <span class="uk-margin-xsmall-right uk-hidden volume-mute-icon" uk-icon="icon:fdn-volume-mute;ratio:1.3"></span>
        </div>
        <input class="uk-range" type="range" value="0.5" min="0" max="1" step="0.1" style="height: 40px;margin-top: -10px;margin-bottom: -10px;">
      </div>
    </div>

    <div class="uk-flex carousel-info-height-wrapper">
      <div class="carousel-info uk-overflow-hidden uk-width-1-1">
        
      </div>
    </div>

    

    <script src="https://imasdk.googleapis.com/js/sdkloader/ima3.js"></script>



    <script>
    // 
  var evVarDebuggingOutput = false
  // 

  function logToConsole () {
    if(typeof evVarDebuggingOutput !== 'undefined' && evVarDebuggingOutput === true) {
      var grayb = 'color:white;background:darkgray;padding:4px;border-radius:4px;'
      console.log('%cReely', grayb, ...arguments)
    }
  }
  function warnToConsole () {
    if(typeof evVarDebuggingOutput !== 'undefined' && evVarDebuggingOutput === true) {
      var orangeb = 'color:white;background:darkorange;padding:4px;border-radius:4px;'
      console.warn('%cReely', orangeb, ...arguments)
    }
  }
  function loggfdnpbjs () {
    if(typeof evVarDebuggingOutput !== 'undefined' && evVarDebuggingOutput === true) {
      var greenb = 'color:white;background:forestgreen;padding:4px;border-radius:4px;'
      console.log('%cfdnpbjs', greenb, ...arguments)
    }
  }
    </script>

    <script>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</script>

    




  </div>
  </div><!-- End .top-stories-video -->

    
  </div>

</div>


  
    </div>
  











  
  
      <div id="LatestInCategory" class="MainColumn ContentDefault ">
        <h3 class="latestcity"><span class="headingText">Latest in City</span></h3>
        <ul class="moduleList ui list grouped expanded">
    
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.thecoast.ca/halifax/do-you-ever-feel-like-a-plastic-bag-obsolete/Content?oid=25104374">
        <img src="https://media1.fdncms.com/thecoast/imager/u/bigsquare/25104881/istock-156268685.jpg"
             alt="Do you ever feel like a plastic bag? Obsolete."
             width="200"
             height="200"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.thecoast.ca/halifax/do-you-ever-feel-like-a-plastic-bag-obsolete/Content?oid=25104374">Do you ever feel like a plastic bag? Obsolete.</a>
    </h4>
    <div class="date"> Oct 30, 2020 </div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.thecoast.ca/halifax/a-look-inside-halifax-regional-councils-head-and-the-next-four-years/Content?oid=25098872">
        <img src="https://media2.fdncms.com/thecoast/imager/u/bigsquare/25099646/collage.jpg"
             alt="A look inside Halifax Regional council&#39;s head and the next four years"
             width="200"
             height="200"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.thecoast.ca/halifax/a-look-inside-halifax-regional-councils-head-and-the-next-four-years/Content?oid=25098872">A look inside Halifax Regional council's head and the next four years</a>
    </h4>
    <div class="date"> Oct 29, 2020 </div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.thecoast.ca/halifax/how-halifax-halloweens-in-2020/Content?oid=25079513">
        <img src="https://media2.fdncms.com/thecoast/imager/u/bigsquare/25079527/img_0259.jpg"
             alt="How Halifax Halloweens in 2020"
             width="200"
             height="200"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.thecoast.ca/halifax/how-halifax-halloweens-in-2020/Content?oid=25079513">How Halifax Halloweens in 2020</a>
    </h4>
    <div class="date"> Oct 27, 2020 </div>
  </li>
    
  
        
            <li class="l0 storyItem more">
              <a href="https://www.thecoast.ca/halifax/ArticleArchives?category=4435354" class="more">More &raquo;</a>
            </li>
          </ul>
        
      </div>
    





  <div id="StorySectionLink" class="MainColumn ContentDefault ">
    <p class="moreArticles"><a href="https://www.thecoast.ca/halifax/news-opinion/Section?oid=957802">more articles in News + Opinion &raquo;</a></p>
  </div> <!-- end StorySectionLink -->











  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="Comments" class="MainColumn ContentDefault CommentsComponent ">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments 
            </div>
            
          </h3>
        </div>
        
        
        <div id="Comments_commentContent" class="commentContent">
          
        </div>
        

        
          <div class="bottomOptionBar clearfix">
            
              <div style="float:left;">
      <div style="float:left;margin:4px 0; padding:4px 6px;">Subscribe to this thread:</div>
      <div style="position:relative;float:left">
      <div class="commentSubscribeLink">
        <a class="toggleActivator saveAction" id="doSubscribe" href="javascript://Subscribe">By Email</a>
      </div>
      <div class="togglePanel" data-toolsoid="25150120" data-toolsajaxmacro="commentSubscribe" style="display:none">
        <div class="toggleArrowBorder"></div>
        <div class="toggleArrow"></div>
        <a href="javascript://close" class="togglePanelClose"><img src="/foundation/images/icons/cross.png" width="14" height="14"></a>
        <div class="loading">Subscribing&hellip;</div>
        <div class="ajaxUpdater" style="display:none;"></div>
      </div>
      </div>
      <div class="commentRSSLink"><a href="/halifax/Rss.xml?id=comments&amp;oid=25150120" class="feedLink" title="Subscribe to this story's comments" target="_blank">With RSS</a></div>
      </div>
            
            
          </div>          
          
        <hr />

        

        
          

          <form id="CommentsPostCommentForm" method="post" class="userCommentForm validateForm" data-validate="login" data-validate-login-options="{&quot;feelingShy&quot;:false}">
            <input type="hidden" name="commentType" value="comment" />
            <input type="hidden" name="oid" value="25150120" />
            <input type="hidden" name="source" value="desktop">

            
            

            <label for="comment" class="hidden">Comment</label>
            
              <h4 class="commentFormAddHeader"><a name="readerComments">Add a comment</a></h4>
            

            
            
            

            <div class="errorDisplay" style="display:none">
              <ol></ol>
            </div>
            <dl class="formElements clearfix">
            
              <dd><textarea name="comment" style="height:112px;overflow:hidden;" tabindex="1" class="expandableBox required" id="comment" data-validate="required"></textarea></dd>
            </dl>

            

            

            <input type="checkbox" name="subscribe" id="Comments_commentSubscribe" value="yes"> <label for="Comments_commentSubscribe" style="margin-right:24px;">Subscribe to this thread</label>
            
            

            <p class="commentFormSubmit">
              <input type="submit" name="commentSubmit" tabindex="2" value="Post Comment" id="commentSubmit" />
            </p>

          </form>
          <script>
            jQuery("textarea.expandableBox").autoBoxResize();
          </script>
        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  









  

  

  
    <div id="MorebyThisAuthorWrapper" class="MainColumn ContentDefault Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="MainColumn ContentDefault ">
            <h3><span class="headingText">More by Seyitan Moritiwon</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.thecoast.ca/Opinionated/archives/2020/10/28/youre-not-too-old-to-trick-or-treat-if-youve-never-celebrated-halloween-before">
        <img src="https://media1.fdncms.com/thecoast/imager/u/bigsquare/25091147/screen_shot_2018-10-22_at_2.29.03_pm.png"
             alt="You&rsquo;re not too old to trick-or-treat if you&rsquo;ve never celebrated Halloween before"
             width="200"
             height="200"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.thecoast.ca/Opinionated/archives/2020/10/28/youre-not-too-old-to-trick-or-treat-if-youve-never-celebrated-halloween-before">You’re not too old to trick-or-treat if you’ve never celebrated Halloween before</a>
    </h4>
    <div class="date"> Oct 28, 2020 </div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.thecoast.ca/halifax/nigerians-in-halifax-are-calling-for-an-end-to-police-brutality-in-nigeria/Content?oid=25053430">
        <img src="https://media2.fdncms.com/thecoast/imager/u/bigsquare/25054268/img_8496.jpg"
             alt="Nigerians in Halifax call for an end to police brutality in Nigeria"
             width="200"
             height="200"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.thecoast.ca/halifax/nigerians-in-halifax-are-calling-for-an-end-to-police-brutality-in-nigeria/Content?oid=25053430">Nigerians in Halifax call for an end to police brutality in Nigeria</a>
    </h4>
    <div class="date"> Oct 22, 2020 </div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.thecoast.ca/halifax/rally-sunday-in-halifax-in-support-of-indigenous-fisherfolks/Content?oid=25013008">
        <img src="https://media2.fdncms.com/thecoast/imager/u/bigsquare/25013304/img_9122.jpg"
             alt="Rally Sunday in Halifax in support of Indigenous fisherfolks"
             width="200"
             height="200"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.thecoast.ca/halifax/rally-sunday-in-halifax-in-support-of-indigenous-fisherfolks/Content?oid=25013008">Rally Sunday in Halifax in support of Indigenous fisherfolks</a>
    </h4>
    <div class="date"> Oct 16, 2020 </div>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.thecoast.ca/halifax/ArticleArchives?author=23800215" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  









      <!-- end gridMainColumn -->
    </div>

    <div id="gridRightColumn">
    
      <!-- ZoneB -->
      <div id="gridMainSidebar">
        











  
      <div id="StickyStoriesRightCol" class="MainSidebar ContentDefault  Home">
        <h3>C19 Need to Know</h3>
        <ul class="moduleList">
    
    

     

  <li class="l0 storyItem">    
    <h4 class="headline itemNoImage">
      <a href="https://www.thecoast.ca/halifax/coronavirus-explained-again/Content?oid=24836664">
        COVID-19 explained 2.0
      </a>
    </h4>
  </li>
       
    
  
    

     

  <li class="l0 storyItem">    
    <h4 class="headline itemNoImage">
      <a href="https://www.thecoast.ca/halifax/what-you-need-to-know-about-wining-and-dining-with-a-mask/Content?oid=24513807">
        Eating out safely
      </a>
    </h4>
  </li>
       
    
  
    

     

  <li class="l0 storyItem">    
    <h4 class="headline itemNoImage">
      <a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/07/31/where-to-get-a-locally-made-mask-in-halifax">
        Locally made masks
      </a>
    </h4>
  </li>
       
    
  
    

     

  <li class="l0 storyItem">    
    <h4 class="headline itemNoImage">
      <a href="https://www.thecoast.ca/newsticker">
        News updates
      </a>
    </h4>
  </li>
       
    
  
    

     

  <li class="l0 storyItem">    
    <h4 class="headline itemNoImage">
      <a href="https://www.thecoast.ca/halifax/pause-the-presses/Content?oid=23704060">
        About the paper Coast
      </a>
    </h4>
  </li>
       
    
  
        </ul>
      </div>
    

<div id="Box1" class="MainSidebar ContentDefault Ad Box">
  <!-- /1020031/Box_New1 -->
          <div id="div-gpt-ad-box_new1" style="" data-content-type="ad" data-slot="/1020031/Box_New1" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-box_new1');
                });
              </script>
          </div>
</div>

<div id="Teaser1" class="MainSidebar ContentDefault Ad Teaser">
  <!-- /1020031/Teaser_New1 -->
          <div id="div-gpt-ad-teaser_new1" style="" data-content-type="ad" data-slot="/1020031/Teaser_New1" data-output="asynchronous" data-width="300" data-height="80">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-teaser_new1');
                });
              </script>
          </div>
</div>

<div id="Box2" class="MainSidebar ContentDefault Ad Box">
  <!-- /1020031/Box_New2 -->
          <div id="div-gpt-ad-box_new2" style="" data-content-type="ad" data-slot="/1020031/Box_New2" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-box_new2');
                });
              </script>
          </div>
</div>

<div id="Teaser2" class="MainSidebar ContentDefault Ad Teaser">
  <!-- /1020031/Teaser_New2 -->
          <div id="div-gpt-ad-teaser_new2" style="" data-content-type="ad" data-slot="/1020031/Teaser_New2" data-output="asynchronous" data-width="300" data-height="80">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-teaser_new2');
                });
              </script>
          </div>
</div>

<div id="Box3" class="MainSidebar ContentDefault Ad Box">
  <!-- /1020031/Box_New3 -->
          <div id="div-gpt-ad-box_new3" style="" data-content-type="ad" data-slot="/1020031/Box_New3" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-box_new3');
                });
              </script>
          </div>
</div>

<div id="Teaser3" class="MainSidebar ContentDefault Ad Teaser">
  <!-- /1020031/Teaser_New3 -->
          <div id="div-gpt-ad-teaser_new3" style="" data-content-type="ad" data-slot="/1020031/Teaser_New3" data-output="asynchronous" data-width="300" data-height="80">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-teaser_new3');
                });
              </script>
          </div>
</div>

<div id="Box4" class="MainSidebar ContentDefault Ad Box">
  <!-- /1020031/Box_New4 -->
          <div id="div-gpt-ad-box_new4" style="" data-content-type="ad" data-slot="/1020031/Box_New4" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-box_new4');
                });
              </script>
          </div>
</div>

<div id="Teaser4" class="MainSidebar ContentDefault Ad Teaser">
  <!-- /1020031/Teaser_New4 -->
          <div id="div-gpt-ad-teaser_new4" style="" data-content-type="ad" data-slot="/1020031/Teaser_New4" data-output="asynchronous" data-width="300" data-height="80">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-teaser_new4');
                });
              </script>
          </div>
</div>

<div id="Box5" class="MainSidebar ContentDefault Ad Box">
  <!-- /1020031/Box_New5 -->
          <div id="div-gpt-ad-box_new5" style="" data-content-type="ad" data-slot="/1020031/Box_New5" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-box_new5');
                });
              </script>
          </div>
</div>

<div id="Teaser5" class="MainSidebar ContentDefault Ad Teaser">
  <!-- /1020031/Teaser_New5 -->
          <div id="div-gpt-ad-teaser_new5" style="" data-content-type="ad" data-slot="/1020031/Teaser_New5" data-output="asynchronous" data-width="300" data-height="80">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-teaser_new5');
                });
              </script>
          </div>
</div>

<div id="DoubleBox" class="MainSidebar ContentDefault Ad DoubleBox">
  <!-- /1020031/DoubleBox_New -->
          <div id="div-gpt-ad-doublebox_new" style="" data-content-type="ad" data-slot="/1020031/DoubleBox_New" data-output="asynchronous" data-width="300" data-height="600">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-doublebox_new');
                });
              </script>
          </div>
</div>
<div id="Box6" class="MainSidebar ContentDefault Ad Box">
  <!-- /1020031/Box_New6 -->
          <div id="div-gpt-ad-box_new6" style="" data-content-type="ad" data-slot="/1020031/Box_New6" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-box_new6');
                });
              </script>
          </div>
</div><div id="Teaser6" class="MainSidebar ContentDefault Ad Teaser">
  <!-- /1020031/Teaser_New6 -->
          <div id="div-gpt-ad-teaser_new6" style="" data-content-type="ad" data-slot="/1020031/Teaser_New6" data-output="asynchronous" data-width="300" data-height="80">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-teaser_new6');
                });
              </script>
          </div>
</div><div id="Box7" class="MainSidebar ContentDefault Ad Box">
  <!-- /1020031/Box_New7 -->
          <div id="div-gpt-ad-box_new7" style="" data-content-type="ad" data-slot="/1020031/Box_New7" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-box_new7');
                });
              </script>
          </div>
</div><div id="Teaser7" class="MainSidebar ContentDefault Ad Teaser">
  <!-- /1020031/Teaser_New7 -->
          <div id="div-gpt-ad-teaser_new7" style="" data-content-type="ad" data-slot="/1020031/Teaser_New7" data-output="asynchronous" data-width="300" data-height="80">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-teaser_new7');
                });
              </script>
          </div>
</div><div id="Box8" class="MainSidebar ContentDefault Ad Box">
  <!-- /1020031/Box_New8 -->
          <div id="div-gpt-ad-box_new8" style="" data-content-type="ad" data-slot="/1020031/Box_New8" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-box_new8');
                });
              </script>
          </div>
</div><div id="Teaser8" class="MainSidebar ContentDefault Ad Teaser">
  <!-- /1020031/Teaser_New8 -->
          <div id="div-gpt-ad-teaser_new8" style="" data-content-type="ad" data-slot="/1020031/Teaser_New8" data-output="asynchronous" data-width="300" data-height="80">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-teaser_new8');
                });
              </script>
          </div>
</div><div id="Box9" class="MainSidebar ContentDefault Ad Box">
  <!-- /1020031/Box_New9 -->
          <div id="div-gpt-ad-box_new9" style="" data-content-type="ad" data-slot="/1020031/Box_New9" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-box_new9');
                });
              </script>
          </div>
</div><div id="Teaser9" class="MainSidebar ContentDefault Ad Teaser">
  <!-- /1020031/Teaser_New9 -->
          <div id="div-gpt-ad-teaser_new9" style="" data-content-type="ad" data-slot="/1020031/Teaser_New9" data-output="asynchronous" data-width="300" data-height="80">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-teaser_new9');
                });
              </script>
          </div>
</div><div id="Box10" class="MainSidebar ContentDefault Ad Box">
  <!-- /1020031/Box_New10 -->
          <div id="div-gpt-ad-box_new10" style="" data-content-type="ad" data-slot="/1020031/Box_New10" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-box_new10');
                });
              </script>
          </div>
</div><div id="Teaser10" class="MainSidebar ContentDefault Ad Teaser">
  <!-- /1020031/Teaser_New10 -->
          <div id="div-gpt-ad-teaser_new10" style="" data-content-type="ad" data-slot="/1020031/Teaser_New10" data-output="asynchronous" data-width="300" data-height="80">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-teaser_new10');
                });
              </script>
          </div>
</div>







  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  




<div id="BoxPromo2" class="MainSidebar ContentDefault Ad Box Promo">
  <!-- /1020031/PromoBox_New2 -->
          <div id="div-gpt-ad-promobox_new2" style="" data-content-type="ad" data-slot="/1020031/PromoBox_New2" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-promobox_new2');
                });
              </script>
          </div>
</div>

<div id="BoxPromo3" class="MainSidebar ContentDefault Ad Box Promo">
  <!-- /1020031/PromoBox_New3 -->
          <div id="div-gpt-ad-promobox_new3" style="" data-content-type="ad" data-slot="/1020031/PromoBox_New3" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-promobox_new3');
                });
              </script>
          </div>
</div>







  <div id="HomeTopTen" class="MainSidebar ContentDefault ">

    <div id="topTenHeader">
     <h2 id="sectionHeader-topten">Coast Top Ten</h2>
      <div class="tabs">
        <div class="tabCurrent tabLeft"><a href="#">Most Read</a></div> 
        <div class="tabBack tabCenter"><a href="#">Most Shared</a></div> 
        <div class="tabBack tabRight"><a href="#">Most Discussed</a></div>
      </div>
    
      <div class="clear"></div>
    
      <div class="topTenBody">
        <ol>
          

          
            
              <li><a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/11/02/covid-19-news-for-the-november-2-week">COVID-19 news for the November 2 week</a> &nbsp; (COVID-19)</li>
            
              <li><a href="https://www.thecoast.ca/halifax/voice-of-the-city-the-show-must-go-on/Content?oid=25138425">Voice of the city: The show must go on</a> &nbsp; (Voice of the City)</li>
            
              <li><a href="https://www.thecoast.ca/halifax/do-you-ever-feel-like-a-plastic-bag-obsolete/Content?oid=25104374">Do you ever feel like a plastic bag? Obsolete.</a> &nbsp; (City)</li>
            
              <li><a href="https://www.thecoast.ca/halifax/the-fruit-flies-in-your-kitchen-are-laying-about-2000-eggs-a-day/Content?oid=24556611">The fruit flies in your kitchen are laying about 2,000 eggs a day</a> &nbsp; (City)</li>
            
              <li><a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/07/31/where-to-get-a-locally-made-mask-in-halifax">Where to get a locally made mask in Halifax</a> &nbsp; (COVID-19)</li>
            
              <li><a href="https://www.thecoast.ca/halifax/rent-controlaltdelete/Content?oid=4467646">Rent Control+Alt+Delete</a> &nbsp; (City)</li>
            
              <li><a href="https://www.thecoast.ca/halifax/canadas-foreclosure-playground/Content?oid=22007305">Inside Canada’s foreclosure playground</a> &nbsp; (City)</li>
            
              <li><a href="https://www.thecoast.ca/halifax/a-look-inside-halifax-regional-councils-head-and-the-next-four-years/Content?oid=25098872">A look inside Halifax Regional council's head and the next four years</a> &nbsp; (City)</li>
            
              <li><a href="https://www.thecoast.ca/halifax/the-best-self-defence-isnt-always-a-good-offence/Content?oid=4404040">The best self-defence isn’t always a good offence</a> &nbsp; (Justice)</li>
            
              <li><a href="https://www.thecoast.ca/halifax/a-creation-story/Content?oid=8111502">A Creation Story</a> &nbsp; (City)</li>
            
          
        </ol>
     
      </div>
    
      <div class="topTenBody" style="display:none">
        <ol>
          
            <li><a href="https://www.thecoast.ca/halifax/portrait-of-the-sakyong-as-a-fallen-man/Content?oid=16329913">Portrait of the sakyong as a fallen man</a> &nbsp; (City)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/the-best-self-defence-isnt-always-a-good-offence/Content?oid=4404040">The best self-defence isn’t always a good offence</a> &nbsp; (Justice)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/michelle-coffin-is-reclaiming-her-story/Content?oid=7685707">Michelle Coffin is reclaiming her story</a> &nbsp; (City)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/nscad-alumni-association-takes-a-vote-of-non-confidence-in-its-president/Content?oid=24810737">NSCAD Alumni Association takes a vote of non-confidence in its president</a> &nbsp; (City)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/the-fruit-flies-in-your-kitchen-are-laying-about-2000-eggs-a-day/Content?oid=24556611">The fruit flies in your kitchen are laying about 2,000 eggs a day</a> &nbsp; (City)</li>
          
            <li><a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/07/31/where-to-get-a-locally-made-mask-in-halifax">Where to get a locally made mask in Halifax</a> &nbsp; (COVID-19)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/whatll-it-take-to-see-someone-other-than-old-white-man-running-this-province/Content?oid=24645699">What'll it take to see someone other than an old white man running this province?</a> &nbsp; (City)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/building-blxckhouse-in-north-preston/Content?oid=20921386">Building BLxCKHOUSE in North Preston</a> &nbsp; (City)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/landlords-getting-the-final-word-on-heritage-designation-wont-work/Content?oid=24591933">Landlords getting the final word on heritage designation won't work</a> &nbsp; (Voice of the City)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/the-school-where-plants-fill-the-halls/Content?oid=25040046">The school where plants fill the halls</a> &nbsp; (City)</li>
          
        </ol>
      
      </div>
    
      <div class="topTenBody" style="display:none">
        <ol>
         
            <li><a href="https://www.thecoast.ca/halifax/canada-post-wants-to-eliminate-my-job-as-a-letter-carrier-heres-why-you-should-care/Content?oid=4155364">Canada Post wants to eliminate my job as a letter carrier. Here’s why you should care</a> &nbsp; (Voice of the City)</li>
          
            <li><a href="https://www.thecoast.ca/RealityBites/archives/2016/10/01/15-questions-with-district-12-candidate-john-bignell">15 questions with District 12 candidate John Bignell</a> &nbsp; (Reality Bites)</li>
          
            <li><a href="https://www.thecoast.ca/Shoptalk/archives/2014/09/18/seadogs-pulls-the-plug">Seadogs pulls the plug (UPDATED)</a> &nbsp; (Shoptalk)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/whatll-it-take-to-see-someone-other-than-old-white-man-running-this-province/Content?oid=24645699">What'll it take to see someone other than an old white man running this province?</a> &nbsp; (City)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/no-political-will-to-fix-nova-scotias-inadequate-tenancy-laws/Content?oid=5788957">No political will to fix Nova Scotia’s inadequate tenancy laws</a> &nbsp; (City)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/halifax-approves-ambitious-and-unprecedented-climate-plan/Content?oid=24301063">Halifax approves ambitious and unprecedented climate plan</a> &nbsp; (City)</li>
          
            <li><a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/10/19/covid-19-news-in-nova-scotia-for-the-week-starting-october-19">COVID-19 news in Nova Scotia, for the week starting October 19</a> &nbsp; (COVID-19)</li>
          
            <li><a href="https://www.thecoast.ca/Opinionated/archives/2020/10/28/youre-not-too-old-to-trick-or-treat-if-youve-never-celebrated-halloween-before">You’re not too old to trick-or-treat if you’ve never celebrated Halloween before</a> &nbsp; (Opinionated)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/hrm-fails-to-consult-community-on-blm-mural-project/Content?oid=24912472">HRM fails to consult community on BLM mural project</a> &nbsp; (City)</li>
          
            <li><a href="https://www.thecoast.ca/halifax/council-approves-three-initiatives-to-try-and-fix-the-housing-crisis/Content?oid=24917626">Council approves three initiatives to try and fix the housing crisis</a> &nbsp; (City)</li>
          
        </ol>
    
      </div>
        
    </div>
  
  </div>




<script type="text/javascript"><!--
  Event.observe(document, "dom:loaded", function () {
      dnSetupTabGroup(
          $$("#HomeTopTen div.tabs>div"),
          $$("#HomeTopTen div.topTenBody"),
          "tabCurrent", "tabBack"
      );
      
      // Deactivate links.
      $$("#HomeTopTen div.tabs>div a").each(function (a) {
          a.onclick = function () { return false; };
      });
  });
//--></script>

<div id="Skyscraper" class="MainSidebar ContentDefault Ad Skyscraper">
  <!-- /1020031/Skyscraper_New -->
          <div id="div-gpt-ad-skyscraper_new" style="" data-content-type="ad" data-slot="/1020031/Skyscraper_New" data-output="asynchronous" data-width="160" data-height="600">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-skyscraper_new');
                });
              </script>
          </div>
</div>





  
    

    
        <div id="SectionBlogs" class="MainSidebar ContentDefault ">
      
      
      
          <h3 class="sectionBlogs-covid_19"><a href="https://www.thecoast.ca/blogs/COVID19Needtoknow/">COVID-19</a></h3>
          <ul>
        
        

        <div class="imageLeadLeft">
        <a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/11/02/covid-19-news-for-the-november-2-week"><img src="https://media2.fdncms.com/thecoast/imager/u/featurette/25143914/november_5_2020_nova_scotia_map_of_covid19_cases_the_coast.png" alt="COVID-19 news for the November 2 week" class="storyImg" /></a>
      </div>
    
  

  
    <p class="sectionTitle">
      
      
      
      COVID-19 &raquo;
    </p>
  

  <h2><a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/11/02/covid-19-news-for-the-november-2-week">COVID-19 news for the November 2 week</a></h2>
  <p style="margin:4px 0 8px 0;">Quick looks at cases and more, in Halifax and Nova Scotia.</p>
  <p class="postedBy">
    
       by TEAM COAST,
    
    Nov  2/20
  </p>


  <div class="hr dotted"><hr /></div>

        
      
        

        <div class="imageLeadLeft">
        <a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/10/27/legendary"><img src="https://media2.fdncms.com/thecoast/imager/u/featurette/25087301/legend_of_the_map_coast.gif" alt="Legendary" class="storyImg" /></a>
      </div>
    
  

  
    <p class="sectionTitle">
      
      
      
      COVID-19 &raquo;
    </p>
  

  <h2><a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/10/27/legendary">Legendary</a></h2>
  <p style="margin:4px 0 8px 0;">What the colours on our COVID-19 map mean, plus a comparison with the province's version.</p>
  <p class="postedBy">
    
       by KYLE SHAW,
    
    Oct 27/20
  </p>


  <div class="hr dotted"><hr /></div>

        
      
        

        <div class="imageLeadLeft">
        <a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/10/26/covid-19-news-in-nova-scotia-for-the-week-starting-october-26"><img src="https://media2.fdncms.com/thecoast/imager/u/featurette/25120061/november_1_2020_nova_scotia_map_of_covid19_cases_the_coast.png" alt="COVID-19 news for the October 26 week" class="storyImg" /></a>
      </div>
    
  

  
    <p class="sectionTitle">
      
      
      
      COVID-19 &raquo;
    </p>
  

  <h2><a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/10/26/covid-19-news-in-nova-scotia-for-the-week-starting-october-26">COVID-19 news for the October 26 week</a></h2>
  <p style="margin:4px 0 8px 0;">Quick looks at cases and more, in Halifax and Nova Scotia.</p>
  <p class="postedBy">
    
       by TEAM COAST,
    
    Oct 26/20
  </p>


  <div class="hr dotted"><hr /></div>

        
      
        

        <div class="imageLeadLeft">
        <a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/10/19/covid-19-news-in-nova-scotia-for-the-week-starting-october-19"><img src="https://media1.fdncms.com/thecoast/imager/u/featurette/25074991/october_25_2020_nova_scotia_map_of_covid19_cases_the_coast.png" alt="COVID-19 news in Nova Scotia, for the week starting October 19" class="storyImg" /></a>
      </div>
    
  

  
    <p class="sectionTitle">
      
      
      
      COVID-19 &raquo;
    </p>
  

  <h2><a href="https://www.thecoast.ca/COVID19Needtoknow/archives/2020/10/19/covid-19-news-in-nova-scotia-for-the-week-starting-october-19">COVID-19 news in Nova Scotia, for the week starting October 19</a></h2>
  <p style="margin:4px 0 8px 0;">New C19 cases and other info bits, mostly but not only from the province.</p>
  <p class="postedBy">
    
       by TEAM COAST,
    
    Oct 19/20
  </p>


  <div class="hr dotted"><hr /></div>

        
      
          </ul>
          <p class="more"><a href="https://www.thecoast.ca/blogs/COVID19Needtoknow/">More &raquo;</a></p>
        
      
    
      
      
          <h3 class="sectionBlogs-opinionated"><a href="https://www.thecoast.ca/blogs/Opinionated/">Opinionated</a></h3>
          <ul>
        
        

        <div class="imageLeadLeft">
        <a href="https://www.thecoast.ca/Opinionated/archives/2020/10/28/youre-not-too-old-to-trick-or-treat-if-youve-never-celebrated-halloween-before"><img src="https://media1.fdncms.com/thecoast/imager/u/featurette/25091147/screen_shot_2018-10-22_at_2.29.03_pm.png" alt="You&rsquo;re not too old to trick-or-treat if you&rsquo;ve never celebrated Halloween before" class="storyImg" width="175" height="125" /></a>
      </div>
    
  

  
    <p class="sectionTitle">
      
      
      
      OPINIONATED &raquo;
    </p>
  

  <h2><a href="https://www.thecoast.ca/Opinionated/archives/2020/10/28/youre-not-too-old-to-trick-or-treat-if-youve-never-celebrated-halloween-before">You’re not too old to trick-or-treat if you’ve never celebrated Halloween before</a></h2>
  <p style="margin:4px 0 8px 0;">Newcomers from all over the world spend their first haunted holiday in Halifax.</p>
  <p class="postedBy">
    
       by SEYITAN MORITIWON,
    
    Oct 28/20
  </p>


  <div class="hr dotted"><hr /></div>

        
      
          </ul>
          <p class="more"><a href="https://www.thecoast.ca/blogs/Opinionated/">More &raquo;</a></p>
        
      
    
        </div>
      
  




    <div id="HomeCoverGallery" class="MainSidebar ContentDefault ">
  
  
  
  
    <div id="issueCover">
      <img src="/images/headers/in-print-this-week.gif" alt="In Print This Week" style="float:left;" />
      <a href="https://www.thecoast.ca/halifax/IssueArchives?issue=24992533"><img src="/imager/b/cover/24992533/3e24/OSPCOMP20201015A01.jpg" alt="Issue Cover" /></a>
      
        <div style="width:130px; margin-top:5px; text-align:center;"><a href="https://www.pressreader.com/canada/the-coast/20201015" target="_blank" class="digitalIcon">Digital Edition</a></div>
      
    </div>
  
  
  <div id="InPrint">
    <h2><a href="https://www.thecoast.ca/halifax/IssueArchives?issue=24992533">In Print This Week</a></h2>
    <small>Vol 28, No 2<br />
    October 15, 2020<br /><br />
    <a href="https://www.thecoast.ca/halifax/IssueArchives">Cover Gallery &raquo;</a></small><br /><br />

  <form name="issueSearchForm" method="get" action="https://www.thecoast.ca/halifax/IssueArchives">
      <select name="issue" onchange="submit();">
        <option value="">Browse Issue by Date</option>
        
           <option value="24992533">October 15, 2020</option>
        
           <option value="24397778">July  9, 2020</option>
        
           <option value="23703168">March 19, 2020</option>
        
           <option value="23657024">March 12, 2020</option>
        
           <option value="23610982">March  5, 2020</option>
        
           <option value="23563432">February 27, 2020</option>
        
           <option value="23516007">February 20, 2020</option>
        
           <option value="23463246">February 13, 2020</option>
        
           <option value="23416192">February  6, 2020</option>
        
           <option value="23365708">January 30, 2020</option>
        
        <option value="">More...</option>
      </select>
    </form>
  </div>
  
  
  
  

    </div>
<div class="clear"></div>
  


        <!-- end gridMainSidebar -->
      </div>

      <!-- ZoneC -->
      <div id="gridMainSidebarJr">
        
        <!-- end gridAdSidebar -->
      </div>

      <!-- ZoneD -->
      <div id="gridMainSidebarJr2">
        
        <!-- end gridAdSidebar2 -->
      </div>
      
      <!-- Zone E -->
      <div id="gridBottomSidebar">
        
        <!-- end gridBottomSidebar -->
      </div>
      
      <!-- end gridRightColumn -->
    </div>

    <!-- Footer -->
    <div id="gridFooter">
      

<div id="Footer" class="GlobalFooter ContentDefault ">

  
      <ul>
    
    
    
    <li>
      <a href="https://www.thecoast.ca/" target="_self">Home</a>
      
        |
      
    </li> 
    
    
  
    
    
    <li>
      <a href="https://www.thecoast.ca/blogs/LovetheWayWeBitch/" target="_self">Bitch</a>
      
        |
      
    </li> 
    
    
  
    
    
    <li>
      <a href="https://www.thecoast.ca/halifax/Section?oid=957802" target="_self">News</a>
      
        |
      
    </li> 
    
    
  
    
    
    <li>
      <a href="https://www.thecoast.ca/halifax/Section?oid=957803" target="_self">Music</a>
      
        |
      
    </li> 
    
    
  
    
    
    <li>
      <a href="https://www.thecoast.ca/halifax/Section?oid=957796" target="_self">Dining</a>
      
        |
      
    </li> 
    
    
  
    
    
    <li>
      <a href="https://www.thecoast.ca/halifax/Section?oid=957805" target="_self">Arts</a>
      
        |
      
    </li> 
    
    
  
    
    
    <li>
      <a href="halifax/best-food-and-drink/BestOf?oid=4437692" target="_self">Best Of</a>
      
        |
      
    </li> 
    
    
  
    
    
    <li>
      <a href="https://www.thecoast.ca/halifax/FAQ/Page" target="_self">FAQ</a>
      
        |
      
    </li> 
    
    
  
    
    
    <li>
      <a href="https://www.thecoast.ca/halifax/CoastStyleGuide/Page" target="_self">Style Guide</a>
      
    </li> 
    
    
  
      </ul>
    

  
      <ul>
    
    

    <li>
      <a href="https://www.thecoast.ca/halifax/AboutUs/Page" target="_self">About Us</a>
      
        |
      
    </li> 

    
  
    

    <li>
      <a href="https://www.thecoast.ca/halifax/OurStaff/Page" target="_self">Our Staff</a>
      
        |
      
    </li> 

    
  
    

    <li>
      <a href="https://www.thecoast.ca/halifax/ContactUs/Page" target="_self">Contact Us</a>
      
        |
      
    </li> 

    
  
    

    <li>
      <a href="https://www.thecoast.ca/halifax/AdvertisingInformation/Page" target="_self">Advertise</a>
      
        |
      
    </li> 

    
  
    

    <li>
      <a href="https://www.thecoast.ca/halifax/WorkWithUs/Page" target="_self">Work With Us</a>
      
        |
      
    </li> 

    
  
    

    <li>
      <a href="https://www.thecoast.ca/halifax/SendATip/Page" target="_self">Send us a Tip</a>
      
        |
      
    </li> 

    
  
    

    <li>
      <a href="https://www.thecoast.ca/halifax/PrivacyPolicy/Page" target="_self">Privacy Policy</a>
      
        |
      
    </li> 

    
  
    

    <li>
      <a href="https://www.thecoast.ca/halifax/CommentsPolicy/Page" target="_self">Comments Policy</a>
      
        |
      
    </li> 

    
  
    

    <li>
      <a href="https://www.thecoast.ca/halifax/Syndication" target="_self"><img src="/images/icons/rss-icon.gif" alt="" border="0" /> RSS Feeds</a>
      
        |
      
    </li> 

    
  
    

    <li>
      <a href="https://www.thecoast.ca/halifax/ArticleArchives" target="_self">Archives</a>
      
    </li> 

    
  
      </ul>
    

</div>

<!-- Start Google Analytics -->
<script type="text/javascript">
  var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
  document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
  try {
    var pageTracker = _gat._getTracker("UA-708653-1");
    pageTracker._trackPageview();
  } catch(err) {}
</script>
<!-- End Google Analytics -->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "8221262" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=8221262&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

<!-- cXense script begin -->
<div id="cX-root" style="display:none"></div>
<script type="text/javascript">
var cX = cX || {}; cX.callQueue = cX.callQueue || [];
cX.callQueue.push(['setAccountId', '9222291968715708015']);
cX.callQueue.push(['setSiteId', '9222304501162646035']);
cX.callQueue.push(['sendPageViewEvent']);
</script>
<script type="text/javascript">
(function() { try { var scriptEl = document.createElement('script'); scriptEl.type = 'text/javascript'; scriptEl.async = 'async';
scriptEl.src = ('https:' == document.location.protocol) ? 'https://scdn.cxense.com/cx.js' : 'http://cdn.cxense.com/cx.js';
var targetEl = document.getElementsByTagName('script')[0]; targetEl.parentNode.insertBefore(scriptEl, targetEl); } catch (e) {};} ());
</script>
<!-- cXense script end -->

<!-- Clicky analytics begin -->
<a title="Real Time Web Analytics" href="http://clicky.com/100675617"><img alt="Real Time Web Analytics" src="//static.getclicky.com/media/links/badge.gif" border="0" /></a>
<script src="//static.getclicky.com/js" type="text/javascript"></script>
<script type="text/javascript">try{ clicky.init(100675617); }catch(e){}</script>
<noscript><p><img alt="Clicky" width="1" height="1" src="//in.getclicky.com/100675617ns.gif" /></p></noscript>
<!-- Clicky analytics end --><div id="footerCopyright">
  <p>
    &copy; 2020
    Coast Publishing Ltd.
  </p>
</div>
      <!-- end gridFooter -->
    </div>
    
    <!-- end gridMain -->
  </div>
  
  <!-- end gridClamp -->
</div>

<!-- Closer -->
<div id="gridCloser">
  
</div><!-- end gridCloser -->


    </body>
</html>
  


